Throttle return spring fell off - Impala Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 05-01-2015, 01:17 PM Thread Starter
Senior Member
 
Join Date: Apr 2015
Location: Atlantic beach
Posts: 287
 
Throttle return spring fell off

Is that little hole in the picture where it's suppose to be?
Attached Thumbnails
Click image for larger version

Name:	image_1430500670231.jpg
Views:	105
Size:	24.7 KB
ID:	11050  
Madencali is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-01-2015, 04:17 PM
Senior Member
 
Join Date: Jun 2014
Location: San Jose, CA
Posts: 285
 
Garage
If that's the spring that goes to the coil bracket than no, It should be lower, if you put it in that hole it's gonna pull the throttle and not return it. If it mounts to the oil fill tube than yes it goes in that hole.
67SS is offline  
post #3 of 6 (permalink) Old 05-01-2015, 04:55 PM Thread Starter
Senior Member
 
Join Date: Apr 2015
Location: Atlantic beach
Posts: 287
 
Quote:
Originally Posted by 67SS View Post
If that's the spring that goes to the coil bracket than no, It should be lower, if you put it in that hole it's gonna pull the throttle and not return it. If it mounts to the oil fill tube than yes it goes in that hole.
It's mounted to thermostat housing. So same difference right?
Madencali is offline  
 
post #4 of 6 (permalink) Old 05-01-2015, 04:57 PM Thread Starter
Senior Member
 
Join Date: Apr 2015
Location: Atlantic beach
Posts: 287
 
Pics to show
Attached Thumbnails
Click image for larger version

Name:	image_1430513890826.jpg
Views:	107
Size:	24.6 KB
ID:	11058  
Madencali is offline  
post #5 of 6 (permalink) Old 05-02-2015, 05:47 AM
Moderator
 
Join Date: Jan 2007
Location: Lewisburg, Ohio
Posts: 2,909
 
Gm used 2 return springs. one inside the other on the quadrajet. I always liked that idea.
dadstoy is offline  
post #6 of 6 (permalink) Old 05-03-2015, 11:59 AM
Senior Member
 
Join Date: Jul 2008
Location: Michigan
Posts: 159
 
That spring looks like its seen better days. Time to new ones.
sz0k30 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome