64 impala rear turn signal problems - Impala Tech
Electrical & Wiring Troubleshooting electrical problems

 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 08-19-2014, 03:51 AM Thread Starter
 
 
Join Date: Aug 2014
Location: nebraska
Posts: 3
 
64 impala rear turn signal problems

First would like to say this is a great place for info! I have been reading and usually find the answer I am looking for so thanks to you all.

My problem is my rear signal lights are not turning on in the dash or rear, gen light does come on. When I press the brake and signal to the left - the right brake light comes on constant and left goes out. This is the same with the right signal as well. I just replaced the starter and voltage regulator.

Is this a bad ground?

I read a post that he was having this same problem but never got to the conclusion because he had a fire in his vehicle that got him to replace the whole harness. I would love to just cruise for the rest of this summer before restoring and replacing to the American classic update. Thanks for the help.
guez2000 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-19-2014, 09:21 AM
Senior Member
 
Join Date: Oct 2009
Location: Orange, CA
Posts: 1,331
Blog Entries: 34
 
Hard to diagnose wiring problems remotely, but the turn signal switch is a common source of goofy behavior in the tail lights



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

1964 Impala 4 door sedan

My Bloggy Thing: http://www.impalas.net/forums/blog.php?u=2285
dcairns is offline  
post #3 of 5 (permalink) Old 08-19-2014, 09:40 AM
Moderator
 
Join Date: Jan 2006
Posts: 12,376
 
Plastics where a new invention in 1964. The white nylon used to form your turn signal is hard and brittle by now and the springiness is long gone. It may well be broken. You will need a few inexpensive tools to take apart the steering column far enough to inspect or to replace the turn signal.

If the bulb is blown in the dash the turn signal will not work. So since that is the cheapest part to replace and no tools are needed I would swap out the bulbs first.

Big Dave
Big Dave is offline  
 
post #4 of 5 (permalink) Old 08-19-2014, 03:04 PM Thread Starter
 
 
Join Date: Aug 2014
Location: nebraska
Posts: 3
 
That's the thing, they where working before I replaced these parts. Checked fuses and they are fine also, guess I will pull the lights on dash and check them next. Let me know if you have any other ideas. Thanks.


Sent from AutoGuide.com Free App
guez2000 is offline  
post #5 of 5 (permalink) Old 10-27-2014, 06:20 PM
 
 
Join Date: Oct 2014
Location: Ca
Posts: 19
 
Did you solve the problems?
Al
496 Impala is offline  
Sponsored Links
Advertisement
 
Reply

Tags
64 impala, tail lights

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome