66 wiper motor- 2spd - Impala Tech
Electrical & Wiring Troubleshooting electrical problems

 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 04-11-2015, 09:27 AM Thread Starter
 
 
Join Date: Apr 2015
Location: NJ
Posts: 5
 
66 wiper motor- 2spd

Need some help with my motor, was working fine, then one day turned on the wiper switch and wiper went on followed in 2 seconds by washer pump continually cycling/clicking/spraying. Same issue lower or high speed setting. (Good news that I get a free shower in the convertible but still annoying.) I swapped out 2 speed switch with another OEM 2spd switch and same results, pump always firing when wipers are ON. Center washer button is operating as designed on both switches, not sticking etc. Any suggestions? Thanks,
zipchip is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 04-11-2015, 02:16 PM
Member
 
Join Date: Aug 2014
Location: Netherlands
Posts: 51
 
Did you check under the plastic cover of the wiper motor?
There is the pump and and an electric actuator that lets the pump be switched on when you press the wiper switch, maybe the mechanical parts there are stuck in "spray" mode.
Dennis J is offline  
post #3 of 8 (permalink) Old 04-13-2015, 02:29 PM Thread Starter
 
 
Join Date: Apr 2015
Location: NJ
Posts: 5
 
Dennis, I can email you a few pics......I see nothing odd under the cover.
zipchip is offline  
 
post #4 of 8 (permalink) Old 04-14-2015, 08:36 PM
Moderator
 
Join Date: Jan 2006
Posts: 12,362
 
Welcome to the Team Tom!

Big Dave
Big Dave is online now  
post #5 of 8 (permalink) Old 04-16-2015, 09:45 PM Thread Starter
 
 
Join Date: Apr 2015
Location: NJ
Posts: 5
 
Thanks Big Dave, picked up a 66 Impala convertible a couple years back, good car, decent shape, 283/220 with PG.
zipchip is offline  
post #6 of 8 (permalink) Old 04-16-2015, 09:48 PM Thread Starter
 
 
Join Date: Apr 2015
Location: NJ
Posts: 5
 
Will a '68 wiper motor bolt right in and replace my '66 2 speed wiper motor? Is the wiring/connectors the same? Thanks.
zipchip is offline  
post #7 of 8 (permalink) Old 04-17-2015, 08:53 AM
Moderator
 
Join Date: Jan 2006
Posts: 12,362
 
If the donor wiper motor was a two speed it will. Look at the switch to see if it has a high and a low speed switch. I'm old enough to remember vacuum wiper motors so older cars had only one speed motors when they went from vacuum to electric. I'm pretty sure that a '66 was a two speed but I can not remember.

Big Dave
Big Dave is online now  
post #8 of 8 (permalink) Old 04-17-2015, 03:37 PM Thread Starter
 
 
Join Date: Apr 2015
Location: NJ
Posts: 5
 
Yes 2 speed switch (and motor) was oem for my car...thanks.
zipchip is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome