Having trouble finding ignition switch for 66 - Impala Tech
Electrical & Wiring Troubleshooting electrical problems

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 10-11-2015, 12:12 AM Thread Starter
 
 
Join Date: Jun 2015
Location: Jonesboro
Posts: 6
 
Having trouble finding ignition switch for 66

I have been searching for an ignition switch for my 1966 Impala. The switch that came with it was a 65 and the switch would not fit right in my dash. On classic industries they show this ignition switch to fit a 66, but it only mentions 67 in the description.

When I search Summit, this ignition switch comes but it shows only 67 also.

Does the 67 switch work in a 66? If not is there anywhere I can buy one?

Thanks
TPress is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-14-2015, 10:49 PM
Senior Member
 
Join Date: Mar 2015
Location: Stillwater, Minnesota
Posts: 328
 
I would call Classic Ind. and ask them about it.

'62 Impala SS 409 TH350
'66 Chevelle SS 496 M20
'70 Chevelle SS 396 M20
'67 Camaro ss/rs 350 PG
'38 Chev coupe street rod
'54 Chev 210 2 door
'69 Chev C10
'89 Chev R3500 roll back
Lost in the 60's is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome