sluggish Sun Pro tach - Impala Tech
Electrical & Wiring Troubleshooting electrical problems

 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 11-18-2015, 10:06 AM Thread Starter
 
 
Join Date: Oct 2015
Location: lombard il
Posts: 14
 
sluggish Sun Pro tach

I have a Sun tac with an HEI ignition. The tac lights,reads 700 at idle but will not go over 1200-1300 rpm. Thanks for any help.
ron zaker jr is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-18-2015, 10:44 AM
Moderator
 
Join Date: Jan 2006
Posts: 12,381
 
Sounds like you have the opposite problem of most tachs and electronic ignitions (non-points). If so you would undo what has been modified to allow the tach to work which was the addition of a resister in the circuit. Sounds like you need to remove the resister attached to the negative terminal.

Big Dave
Big Dave is offline  
post #3 of 5 (permalink) Old 11-18-2015, 11:07 AM Thread Starter
 
 
Join Date: Oct 2015
Location: lombard il
Posts: 14
 
Thank you for responding. I am not sure where that resistor would be? I have a 4 wire hook up with no additional parts. Thank you.
ron zaker jr is offline  
 
post #4 of 5 (permalink) Old 11-18-2015, 05:35 PM
Moderator
 
Join Date: Jan 2006
Posts: 12,381
 
According to the instructions when you convert from points to an HEI you add a resister to the line to make the square wave that the tach sees look more like a points ignition. But you usually add the resister to lower the tach reading high or bouncing all over the place. Those are not the symptoms you described.

I would contact Sun to see what it costs to get it working properly. Or you can contact these guys:

http://dandmrestoration.com/tag/tachometers/

Big Dave
Big Dave is offline  
post #5 of 5 (permalink) Old 11-19-2015, 09:44 AM Thread Starter
 
 
Join Date: Oct 2015
Location: lombard il
Posts: 14
 
will do thank you again.
ron zaker jr is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome