1965 impala electrical cut off problem - Impala Tech
Electrical & Wiring Troubleshooting electrical problems

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 09-16-2017, 09:32 PM Thread Starter
Senior Member
 
Join Date: Mar 2006
Posts: 4,294,967,289
 
1965 impala

*******

Last edited by gmc79; 09-18-2017 at 08:17 AM.
gmc79 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-17-2017, 01:20 PM
Moderator
 
Join Date: Jul 2009
Location: Canada
Posts: 1,391
 
First, and most likely: bad battery connection. Very common. Just remove the battery terminals, clean carefully, use baking soda and water to dissolve corrosion, clean posts and inside cable ends with sandpaper, refasten tightly. I would also carefully check the wire from the starter to the coil.

Two doors, four doors, wagons, and ragtops.
jayoldschool is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome