LED signal lights - Impala Tech
Electrical & Wiring Troubleshooting electrical problems

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 03-11-2019, 12:52 AM Thread Starter
Member
 
Join Date: Apr 2009
Location: North County San Diego
Posts: 37
 
Garage
LED signal lights

I've installed 1157 Zevo led bulbs on my 62 impala, front signal lights are on but a bit dim and rear tail lights work great when I pull headlight switch knob. Also when I press on brakes rears light up good. Turn signals do not work though just light up on either direction signal lever is switched to. What can I do to fix this?

6*IMPALA*2
Skyverado13 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-16-2019, 09:01 AM
 
 
Join Date: Jun 2014
Location: Queensbury, NY
Posts: 3
 
You need to change the flasher to one that works with LED's, worked for my 47 Ford, changed to 12 volts and LED lights. Good luck.
oldcarguy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome