66 Impala Taillight Issues - Impala Tech
Electrical & Wiring Troubleshooting electrical problems

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 05-12-2013, 12:02 AM Thread Starter
 
 
Join Date: Oct 2011
Location: Elizabethtown Ky
Posts: 8
 
66 Impala Taillight Issues

Hello,
I hope someone can give me some assistance. I am having some issues with my taillights on my 66 2 door non SS. First, my turn signals work. I currently have no taillights or brake lights at all. They were working last night, but when I got into the car today I had no taillights. When I turn on my headlight switch, the headlights come on just fine. My fuel gage also goes to empty when I turn on my headlights. This fuel gage problem also just started this morning at the same time my taillights went out. I checked all the fuses and they were fine. My grounds also look ok. I also changed out my headlight switch last month. Everything had been working fine since the switch change. Maybe there is something that I am overlooking. Thanks for any help that you guys can provide.
powerpack is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-12-2013, 08:43 AM
Moderator
 
Join Date: Jan 2007
Location: Lewisburg, Ohio
Posts: 2,909
 
Most problems with 65-66 Impala taillights are grounds not making good connections. GM used the socket to ground the lights. It worked OK when new but after almost 50 years the wiring and sockets need a up grade. I fought with getting my taillights all to work at one time and correctly for years.
dadstoy is offline  
post #3 of 3 (permalink) Old 05-12-2013, 05:43 PM Thread Starter
 
 
Join Date: Oct 2011
Location: Elizabethtown Ky
Posts: 8
 
Thanks for the reply. I got my taillights working again. Now the only problem I have is the fuel gage goes to empty when I turn on my high beams. The fuel gage also goes to empty when I turn on my interior lights. Does anyone have anymore ideas on this problem?
powerpack is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome