New to the TEAM and i already have a question! - Impala Tech
Electrical & Wiring Troubleshooting electrical problems

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 07-09-2013, 09:22 PM Thread Starter
 
 
Join Date: Jul 2013
Location: North Hills, CA.
Posts: 1
 
Question New to the TEAM and i already have a question!

Hi Everyone out there reading this! I'm excited i found a forum dedicated specifically to Impalas. i have a 2003 Impala and it's been an absolute angel up until a week ago where things started acting up. I am worried that i might have electrical problems. Lights that should not be on are turning on and visa versa. My CRUISE control light turns on and at time flickers. My over head temp reader screen turns off? Could this mean it's the beginning of something serious?
Lucye5776 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-09-2013, 09:45 PM
Moderator
 
Join Date: Jul 2009
Location: Canada
Posts: 1,391
 
The correct forum for your FWD Impala:

http://www.impalaforums.com/

Two doors, four doors, wagons, and ragtops.
jayoldschool is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome