1996 wiper problem - Impala Tech
Troubleshooting Diagnosing problems

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 07-16-2008, 08:51 PM Thread Starter
 
 
Join Date: Jul 2008
Location: Destin, Florida
Posts: 1
 
1996 wiper problem

My wipers have quit working on my 1996 SS. The fuse is fine; a mechanic at a tire store says that a remanufactured wiper motor did not solve the problem (although I'm starting to wonder if he did anything); and I have replaced the switch on the turn signal lever. I know that the wiper motor has an internal circuit breaker, but can it be replaced without replacing the entire wiper motor? Has anyone else had this problem?
delmarhughes is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome