03 Impala Rear Defrost - Impala Tech
Troubleshooting Diagnosing problems

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 12-09-2008, 06:42 PM Thread Starter
 
 
Join Date: Dec 2008
Location: mass
Posts: 1
 
03 Impala Rear Defrost

im competely lost im very good with automotive wiring, but the rear defrost in this car is driving me nuts. Ive got 12v to the plug that goes to the window until I make the connection at the window as soon as I do this the voltage drops off. The ground on the other side is good and ive replaced the relay in the fuse box and the module behind the drivers fly window if anyone can help it would be great!!!
04cummins is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome