Gas Gauge Help - Impala Tech
Troubleshooting Diagnosing problems

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 05-05-2009, 11:56 PM Thread Starter
 
 
Join Date: May 2009
Location: washington
Posts: 12
 
Exclamation Gas Gauge Help

I just bought my first 64 Impala. The Fuel Gauge is stays between half a tank and 3/4 a tank. Where do i start to look at what this problem might be. I see most people it is in the wiring from what I read. Mine does not have the same chateristics as everyone else. Turning on any of the other power sources do not seem to affect it at all. What should I do?
waters 64 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-06-2009, 09:50 AM
Senior Member
 
Join Date: Sep 2006
Location: Santee, SC
Posts: 960
 
Check for a good clean ground from the tank unit to the frame...you will see the wire. remove the bolt to the frame and clean off the surfaces to bare metal, put it back on and see if that fixes the prob.
dgwar is offline  
post #3 of 4 (permalink) Old 05-06-2009, 12:22 PM
Member
 
Join Date: Sep 2008
Location: surrounded by Coopers
Posts: 50
 
i'm a ChevyII owner, so i may be a little unfamiliar with what's available for reproduction parts etc for your car but if it were me, after checking grounds/connections etc as suggested i think i'd swap out the sender regardless. as old as it is i'd bet a nickle the fuel intake "sock" is somewhat deteriorated. the sock is located at the end of the sender... i'd also think seriously about dropping the tank and either flushing or outright replacing it. IF one is available that is.


i've owned a lot of older Chevy's in my day and one of the biggest headaches is a dirty, rusty gas tank. they do nothing but give you filter & carb problems.


my info may not be helpful to you, just a suggestion.


good luck,


JR
SHIFTY4 is offline  
 
post #4 of 4 (permalink) Old 05-06-2009, 08:01 PM Thread Starter
 
 
Join Date: May 2009
Location: washington
Posts: 12
 
Thank you for the sugestions. I will check the ground to start with. if that does not work i will let you guys know. I am excited this is my first classic.

I will check the sender next and probably replace it as well. I plan on replacing and referbishing everything as I go along
waters 64 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome