04 Impala - haunted - Impala Tech
Troubleshooting Diagnosing problems

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 11-06-2009, 11:43 PM Thread Starter
 
 
Join Date: Nov 2009
Location: Texas
Posts: 1
 
Question 04 Impala - haunted

My 04 Impala has some strange things happening with the gauges, sometimes they work and sometimes they don't. It varies from time to time they may all go wacky at once or one at a time. The RPM can be reset if I turn the key on and off till it gets to the 0, however it will go back when it wants to. What is it? It's driving me crazy.
Suzs is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-07-2009, 11:39 PM
Senior Member
 
Join Date: Mar 2009
Location: DuPage County, Illinois
Posts: 121
Blog Entries: 6
 
Did you try to disconnnect the battery for like 20 minutes? Sometimes when you do that the computer resets itself to factory settings, you will lose your time and presets on your radio, but it sounds like your gauge cluster is more important than that. If not you might have some wires crossed somewhere down the line, you dont have a custom stereo in there do you, becasue if it was done wrong it can wreak havoc on your system? Let me know if any of this works!
robklein13 is offline  
post #3 of 3 (permalink) Old 11-11-2009, 06:17 PM
Member
 
Join Date: May 2009
Location: Mobile, AL
Posts: 82
 
most of the gauges in your car are "slave" units that are commanded by a logic module inside the cluster based on serial data messages received from other modules in the car. More than likely just a faulty IPC, which you will have to get on exchange from an AC Delco repair facility through your local dealer and it MUST be programmed to ever work. Also, like Rob said, I'm assuming you or no one else has been monkeying around with the electrical system. I have personally seen one wrong wire hooked up on a stereo install that took out three other modules to the tune of around $2k in repairs.
ujsf01 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome