05 impala 3.4l water pump - Impala Tech
Troubleshooting Diagnosing problems

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 04-26-2011, 08:02 AM Thread Starter
 
 
Join Date: Apr 2011
Location: denver
Posts: 1
 
05 impala 3.4l water pump

I have a 2005 base Impala, 3.4l engine. After a drive to vegas from Denver I noticed that the car was leaking coolant. I am in no way a mechanic but it seems to be coming out of the water pump. I need to know how hard would it be to change the water pump, and if this sounds like a water pump issue. Also do I need any "special" tools or knowledge that would help? Thanks for an assistance on this...

Chris
crumbs300 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-26-2011, 10:45 PM
Senior Member
 
Join Date: Nov 2010
Location: West Jefferson, Ohio
Posts: 270
 
It's about the easiest water pump you could ever have to change.

With the belt still on, loosen the water pump pulley bolts. Remove belt. Remove pulley. Remove the 5 bolts retaining the water pump, then pull the pump off the motor (coolant will then spill out). Clean off the old gasket. Put it all back together and fill the coolant.

These pumps normally take me about 15 minutes to change.

'69 Impala 4-door hardtop
'70 Impala Custom coupe
AK99 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome