p1404 - Impala Tech
Troubleshooting Diagnosing problems

 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 01-01-2013, 09:51 AM Thread Starter
 
 
Join Date: Jan 2013
Location: Michigan
Posts: 1
 
p1404

First and foremost, "Happy New Year" everyone.

I have a 2001 Impala LS with a 3800. My issues is this. I initially cleaned my egr after getting the p1404 code, I then replaced the egr valve (AC Delco). Yet after a day or two the check engine light is back on with the p1404 code. I tried the reset I found online, by disconnecting the egr valve...erasing code...then reconnect, and the check engine light comes back (again). The car rides great and there are no emission issues.

Can anyone help or offer any suggestions?
phillypoet313 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-02-2013, 02:08 PM
Moderator
 
Join Date: Jan 2007
Location: Lewisburg, Ohio
Posts: 2,909
 
I don't know if this helps or not ,but a friend of mine has a Impala like yours and also had EGR problems. After replaceing the valve the problem reoccurs. The intake manifold had to be cleaned out. The carbon buildup plugs up the orifice where the EGR valve mounts.
dadstoy is offline  
post #3 of 5 (permalink) Old 01-03-2013, 02:39 PM
Member
 
Join Date: Sep 2012
Location: Accord, NY
Posts: 61
 
I'd remove the egr again and look around to see if there's more carbon buildup in the passages.

When you replaced the unit, what did the old one that you recently cleaned look like?

Although the car seems to be running fine, the code says the pindle is stuck open. Maybe partially.
Rick Dorion is offline  
 
post #4 of 5 (permalink) Old 01-03-2013, 02:48 PM
Moderator
 
Join Date: Jan 2007
Location: Lewisburg, Ohio
Posts: 2,909
 
Wasn't my car. All I know is he had to have the intake cleaned out to solve his problem.
dadstoy is offline  
post #5 of 5 (permalink) Old 01-04-2013, 12:59 PM
Member
 
Join Date: Sep 2012
Location: Accord, NY
Posts: 61
 
Sorry. I meant to the OP.
Rick Dorion is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome