faulty fuel reading - Impala Tech
Troubleshooting Diagnosing problems

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 02-25-2013, 04:20 PM Thread Starter
 
 
Join Date: Feb 2013
Location: Auburn AL
Posts: 1
 
faulty fuel reading

I have a 2003 3.4L impala. Just got a code for the upstream oxygen sensor, picked up the part from the store and changed it. I filled up my tank, drove about 20 miles and the check engine light went off. After about 300 miles on the same tank it was still reading at full then it went to half and it was shifting shifting everywhere in between. Not sure whats going on but the gas gage isnt reading right.
Jerald is offline  
Sponsored Links
Advertisement
 
Reply

Tags
fuel mileage, gas gauge, oxygen sensor

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome