2004 Impala Stopped Running on Freeway - Impala Tech
Troubleshooting Diagnosing problems

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 05-23-2013, 04:41 PM Thread Starter
 
 
Join Date: May 2013
Location: Cincinnati
Posts: 2
 
2004 Impala Stopped Running on Freeway

My 2004 Impala SS, 3.8 Supercharged motor, has been running fine for 325,000 miles, but 2days ago while going 60 mph, very quickly lost power and regained it almost instantaneously. Drove home another 10 miles without incident. Yesterday after driving only 5 minutes, the engine shut off while doing 65 mph. Coasted to the side, restarted and drove another few miles in stop and go traffic and a drive thru then while sitting in a parking lot is started to run rough like I was running out of gas (I have a half tank) and finally stopped running. I restarted and it ran very roughly like it is not getting enouhg gas for about 30 seconds then died. It would not restart, but it is trying to fire. I had it towed home. This morning, I started it, it ran fine for 2 seconds then ran very rough like out of gas for 2 seconds and stopped. Any suggestions on where to start? I'm guessing Fuel Pump or Fuel Filter.
johntm is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-23-2013, 05:23 PM
Moderator
 
Join Date: Jul 2009
Location: Canada
Posts: 1,402
 
Classic symptoms of a failing/failed fuel pump.

BTW, here is the forum you want for your late model FWD Impala:

http://www.w-body.com/forum.php

Two doors, four doors, wagons, and ragtops.
jayoldschool is offline  
post #3 of 4 (permalink) Old 05-23-2013, 05:30 PM Thread Starter
 
 
Join Date: May 2013
Location: Cincinnati
Posts: 2
 
That's what I was afraid of - they certainly are expensive!
johntm is offline  
 
post #4 of 4 (permalink) Old 05-23-2013, 07:53 PM
Moderator
 
Join Date: Jul 2009
Location: Canada
Posts: 1,402
 
If you figure dollar/mile, you did pretty well on the old one

Two doors, four doors, wagons, and ragtops.
jayoldschool is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome