New member in Duluth MN - Impala Tech
Welcome Forum New to the site? Introduce yourself.

 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 07-02-2014, 08:27 PM Thread Starter
 
 
Join Date: Jul 2014
Location: Duluth MN
Posts: 4
 
New member in Duluth MN

Hi!
I just acquired a gorgeous '68 Impala and am looking forward to some fun weekends this summer!
I will be looking for info related to the heater/AC blower not working. Previous owner said it worked fine until he had someone install an a/m CD player. Anyone have experience removing the heater controls from the dash? I want to try looking at possible easy problem sources and fixes before digging into the actual heater core area. I'll scan the forums too now that I'm registered.
Thanks,
Bob
rjbursell is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-03-2014, 07:50 AM
Senior Member
 
Join Date: Sep 2008
Location: Fort Worth Texas
Posts: 1,273
 
Check your fuse and wiring. Dont remove the controls that could be a big mess. Run a hot wire to the motor to see if it actually does work.
Txbobcat is offline  
post #3 of 5 (permalink) Old 07-04-2014, 08:45 AM
Moderator
 
Join Date: Jan 2007
Location: Lewisburg, Ohio
Posts: 2,909
 
Welcome Bob, I doubt the dash controls are bad. May be the blower relay if it has air.
dadstoy is offline  
 
post #4 of 5 (permalink) Old 07-05-2014, 08:19 AM
Member
 
Join Date: Sep 2012
Location: IL
Posts: 65
 
Quote:
Originally Posted by rjbursell View Post
Hi!
I just acquired a gorgeous '68 Impala and am looking forward to some fun weekends this summer!
I will be looking for info related to the heater/AC blower not working. Previous owner said it worked fine until he had someone install an a/m CD player. Anyone have experience removing the heater controls from the dash? I want to try looking at possible easy problem sources and fixes before digging into the actual heater core area. I'll scan the forums too now that I'm registered.
Thanks,
Bob
Post up some pics of the new ride.
alocker is offline  
post #5 of 5 (permalink) Old 07-05-2014, 03:15 PM
Moderator
 
Join Date: Jan 2006
Posts: 12,455
 
Welcome to the team Bob!

Don't try to fix that which isn't broke. The problem will be in the wiring not in the switch and mechanical cables that comprise the A/C dash control unit.

As pointed out the A/C is a high electrical demand. So there are relays to control the heavy electrical loads (with added wiring) for your blower motor and the A/C clutch.

Big Dave
Big Dave is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome