05 Chevy Impala Inner front tire wear - Impala Tech
Welcome Forum New to the site? Introduce yourself.

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 09-18-2014, 04:29 PM Thread Starter
 
 
Join Date: Sep 2014
Location: Calais, Maine
Posts: 2
 
05 Chevy Impala Inner front tire wear

I have an 05 impala that the right front tire has worn out extremely fast and blown out. I took it to VIP and they said the only thing wrong is my front a-arm bushing is completely worn out. Would that cause the tire to wear so bad? How do you check if a strut is worn out?
stephenday89 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-18-2014, 04:31 PM Thread Starter
 
 
Join Date: Sep 2014
Location: Calais, Maine
Posts: 2
 
The tire looked like it was crooked like the camber or caster was out
stephenday89 is offline  
post #3 of 3 (permalink) Old 09-18-2014, 08:11 PM
Moderator
 
Join Date: Jul 2009
Location: Canada
Posts: 1,389
 
Hi Steve.

This forum focuses on classic RWD Impalas from the 1960s. For advice on your late model FWD, check out www.impalaforums.com

Two doors, four doors, wagons, and ragtops.
jayoldschool is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome