2014 impala electric problems - Impala Tech
Welcome Forum New to the site? Introduce yourself.

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 09-29-2014, 05:00 PM Thread Starter
 
 
Join Date: Sep 2014
Location: 77028
Posts: 1
 
2014 impala electric problems

No sound no chimes no display......soon after 36000 miles...coincidence or intentionally designed
dre1day is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-29-2014, 06:32 PM
Moderator
 
Join Date: Jul 2009
Location: Canada
Posts: 1,399
 
1. It's under warranty. Back to the dealer.
2. This forum is for classic 1960s RWD Impalas.
3. "intentionally designed" makes this seem like a troll post.

Closed.

Two doors, four doors, wagons, and ragtops.
jayoldschool is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome