Blower motor dead, 2000 Impala - Impala Tech
Welcome Forum New to the site? Introduce yourself.

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 11-05-2014, 09:17 AM Thread Starter
ted
 
 
Join Date: Nov 2014
Location: maine
Posts: 1
 
Blower motor dead, 2000 Impala

2000 Impala 3.8l ----Old Fan blower motor was very noisy... replaced it with new one that I tested on bench (runs well). Won't run in car. . Old motor never would run on anything but hi-speed.Tested plug to fan, No volts any position on fan switch. Pulled the two 25a fan fuses, tested ok with ohm meter, and fuse sockets have 12vdc on right side. Swapped fan cont relays, no change.Then tested all fuses in both boxes, all OK. What's going on????
Any body got any suggestions of what to do next? I would greatly appreciate it.
I don't want to take it to the dealer unless as last resort.

Tx, Ted without defrost in Maine.
ted is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-06-2014, 12:19 AM
Senior Member
 
Join Date: Apr 2013
Location: Canada
Posts: 324
 
I think you will have good luck asking your question over at www.impalaforums.com where they have a section for your era of Impala. This forum caters to the classic Impalas from way back when!
Darth is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome