New guy - Impala Tech
Welcome Forum New to the site? Introduce yourself.

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 11-02-2011, 05:21 PM Thread Starter
 
 
Join Date: Nov 2011
Location: summerville, sc
Posts: 2
 
New guy

Hi i'm the new guy and i have a question about my impala. I have a 2000 impala base model with a 3400 in it and the head gaskets went and a bad knock in the oil pan. I ordered a new engine from a company on ebay it only cost me 550 but they sent me a 3400 chevy venture engine. At first i thought okay maybe it will work but then i started noticing different connectors and even the heater hose crossover tubes were different. What do i have to do to get this engine to work properly or should i just send it back and take my lost on the restocking fee....how much switching over do i really have to do?
dcoad412 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome