heat problems - Impala Tech
Welcome Forum New to the site? Introduce yourself.

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 03-11-2012, 02:32 PM Thread Starter
 
 
Join Date: Mar 2012
Location: MB,NY
Posts: 1
 
Question heat problems

i have a 2009 impala ltz love my car.
i need help trying to find out about a problem with the heat.
Whwn in idle the car blows cold air and it takes a long time to warm up.
any ideas please post.
thanks
nmg60 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-11-2012, 08:36 PM
Senior Member
 
Join Date: Apr 2010
Location: Monroe NC
Posts: 1,094
 
Assuming your car is not overheating and gauges are reading normal, feel the hoses going into the heater core. Both hoses should feel about the same temprature, if not then you have a blocked heater core.

If hoses are the same, then it could be your heater resistor, which is a DIY if you have a repair book to show you where its located.

And finally if all the above is good then its your blending door that could be stuck or broke.
68imp is offline  
Sponsored Links
Advertisement
 
Reply

Tags
heat problems 2009 ltz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome