Clone 350tbi and Impala 63?? - Impala Tech
Performance Our High Performance Area

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 05-20-2010, 04:02 PM Thread Starter
 
 
Join Date: Dec 2009
Location: Sweden
Posts: 9
 
Clone 350tbi and Impala 63??

Hey!
All tips about a project like the topic would be to ig help for me.
I do have a complete chevy van with 350tbi/th700 and i would like to place this in my 63.



Regards
Gustaf

My ride is an Chevrolet Impala 4dr HT 1963 19800miles, 2 owners in the states before it was shipped to Sweden and my garage.
Gustaf_h is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-20-2010, 07:46 PM
Moderator
 
Join Date: Jan 2006
Posts: 12,383
 
Rip it out and stuff it in. The 700R4 is a tad longer than the TH350/PowerGlide you have now. You will need all of the wiring and computer out of the van to install in your Impala. The pan might be a bit tight with your cross-member as truck pans are lower slung since they don't have road clearance issues that cars do.

Other wise every thing should bolt right up.

Big Dave
Big Dave is offline  
post #3 of 4 (permalink) Old 08-09-2010, 06:19 AM Thread Starter
 
 
Join Date: Dec 2009
Location: Sweden
Posts: 9
 
Thanks Dave,

I think i skip to mount the 350 enginge with computer boxes and everything. Instead i take the manifold and 4brl carburator from the 327 and put it on the 350 enginge.

How is it to mount Headers on a old 63chevy with a bit moore modern 350 enginge? I guess it would not be any bigger problems?

/GUSTAF

My ride is an Chevrolet Impala 4dr HT 1963 19800miles, 2 owners in the states before it was shipped to Sweden and my garage.
Gustaf_h is offline  
 
post #4 of 4 (permalink) Old 08-09-2010, 08:25 AM
Moderator
 
Join Date: Jan 2006
Posts: 12,383
 
The wonder of the Chevrolet is the amount of parts interchangeability. a set of headers to fit your car are the same if you put a 1955 265 small block in or if you put in a small block Chevy Vortec engine out of a 2001 pick-up truck (even though the "D" port heads have an issue with exhaust leaks the headers will still holt right up and seal initially).

Big Dave
Big Dave is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome