68 396 block id - Impala Tech
Tag Team De-coding tags & numbers

 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 12-18-2010, 12:56 PM Thread Starter
 
 
Join Date: Feb 2010
Location: OK
Posts: 9
 
68 396 block id

I have a #440 casting 396 block. The stamp pad reads:
18S241707
T0513IV

I know "0513IV" indicates May 13th assembly and 325hp/396cid automatic tranny.
Using the partial vin can anyone help identify the car model this block was originally in? Could it have been an Impala?

Thanks
ChrisM is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 12-18-2010, 01:26 PM
 
 
Join Date: Apr 2010
Location: Canada
Posts: 14
 
From the info I have the "IV" indicates a 1966 396 325 HP.
All I get is Chevrolet. Maybe someone else has better information on the application.

69 Impala 396 Conv.
dusty is offline  
post #3 of 6 (permalink) Old 12-18-2010, 05:44 PM Thread Starter
 
 
Join Date: Feb 2010
Location: OK
Posts: 9
 
Smile

Quote:
Originally Posted by dusty View Post
From the info I have the "IV" indicates a 1966 396 325 HP.
All I get is Chevrolet. Maybe someone else has better information on the application.
18S at beginning of partial vin stamped on pad indicates:
1 = Chevorlet
8 = 1968 model year
S = St. Louis assembly plant, so passenger cars and corvettes.

Date cast into block is May 7 1968. Definitely not 1966, but thanks for trying.
ChrisM is offline  
 
post #4 of 6 (permalink) Old 12-18-2010, 09:34 PM
Member
 
Join Date: Feb 2009
Location: ,Connecticut
Posts: 63
 
Engine code IV is from a 68 Impala/ full size. Chevelle codes start with E , Camaros start with M. In 68, all big block Impala codes have I for the first letter. Don S
68SS427 is offline  
post #5 of 6 (permalink) Old 12-18-2010, 11:25 PM Thread Starter
 
 
Join Date: Feb 2010
Location: OK
Posts: 9
 
Thank you Don.
ChrisM is offline  
post #6 of 6 (permalink) Old 12-19-2010, 02:42 AM
 
 
Join Date: Dec 2009
Location: Wisconsin
Posts: 8
 
That 68 Impala IV code engine came with a turbohydramatic trans.

Last edited by RealRed70; 12-19-2010 at 02:42 AM. Reason: more info
RealRed70 is offline  
Sponsored Links
Advertisement
 
Reply

Tags
241707, 396

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Impala Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome